myairops Service Impact Notification - myairops flight platform

Incident Report for myairops UK

Resolved

Hi

We would like to share an update that the root cause of this issue is now fully resolved. Based on our monitoring, myairops users are now experiencing normal service in using the platform. We will move this incident to Resolved.

Regards, myairops Support
Posted Jun 20, 2025 - 00:05 BST

Monitoring

Our DevOps team has implemented a fix to address the root cause - we will continue to monitor the situation before classing the incident as Resolved.

Regards, customer Support
Posted Jun 19, 2025 - 19:01 BST

Identified

We’re currently experiencing a degraded service with certain functions in myairops flight and myairops crew. Users may be affected when trying to load certain trips in the myairops crew app, as well as navigating to selected areas in myairops flight. Our team is aware of the root cause, and is currently working to restore normal service levels.

We apologise for any inconvenience and will post another update as soon as we learn more.

Regards, myairops Support
Posted Jun 19, 2025 - 17:08 BST
This incident affected: myairops flight (flight App) and myairops crew.